CVE-2019-14380

NameCVE-2019-14380
Descriptionlibopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2 files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4729-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libopenmpt (PTS)stretch0.2.7386~beta20.3-3+deb9u3fixed
stretch (security)0.2.7386~beta20.3-3+deb9u4fixed
buster, buster (security)0.4.3-1+deb10u1fixed
bullseye, sid0.4.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libopenmptsourcestretch(not affected)
libopenmptsourcebuster0.4.3-1+deb10u1DSA-4729-1
libopenmptsource(unstable)0.4.5-1low

Notes

[stretch] - libopenmpt <not-affected> (Vulnerable code not present in 0.2 branch)
https://lib.openmpt.org/libopenmpt/2019/05/27/security-update-0.4.5/

Search for package or bug name: Reporting problems