CVE-2019-14382

NameCVE-2019-14382
DescriptionDSM in libopenmpt before 0.4.2 allows an assertion failure during file parsing with debug STLs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libopenmpt (PTS)stretch0.2.7386~beta20.3-3+deb9u3vulnerable
buster0.4.3-1fixed
bullseye, sid0.4.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libopenmptsource(unstable)0.4.2-1unimportant

Notes

https://lib.openmpt.org/libopenmpt/2019/01/22/security-updates-0.4.2-0.3.15-0.2.11253-beta37-0.2.7561-beta20.5-p13-0.2.7386-beta20.3-p16/
https://source.openmpt.org/browse/openmpt/trunk/?op=revision&rev=11209
Negligible security impact

Search for package or bug name: Reporting problems