CVE-2019-14459

NameCVE-2019-14459
Descriptionnfdump 1.6.17 and earlier is affected by an integer overflow in the function Process_ipfix_template_withdraw in ipfix.c that can be abused in order to crash the process remotely (denial of service).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs933740

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nfdump (PTS)stretch1.6.15-3vulnerable
buster1.6.17-1vulnerable
bullseye, sid1.6.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nfdumpsource(unstable)1.6.18-1medium933740

Notes

https://github.com/phaag/nfdump/issues/171
https://github.com/phaag/nfdump/commit/3b006ededaf351f1723aea6c727c9edd1b1fff9b

Search for package or bug name: Reporting problems