CVE-2019-14468

NameCVE-2019-14468
DescriptionGnuCOBOL 2.2 has a buffer overflow in cb_push_op in cobc/field.c via crafted COBOL source code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs933884

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnucobol (PTS)bullseye, sid, buster2.2-5vulnerable
open-cobol (PTS)jessie1.1-1vulnerable
stretch1.1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnucobolsource(unstable)(unfixed)933884
open-cobolsource(unstable)(unfixed)

Notes

[buster] - gnucobol <no-dsa> (Minor issue)
[stretch] - open-cobol <no-dsa> (Minor issue)
[jessie] - open-cobol <no-dsa> (Minor issue)
https://sourceforge.net/p/open-cobol/bugs/581/

Search for package or bug name: Reporting problems