CVE-2019-14513

NameCVE-2019-14513
DescriptionImproper bounds checking in Dnsmasq before 2.76 allows an attacker controlled DNS server to send large DNS packets that result in a read operation beyond the buffer allocated for the packet, a different vulnerability than CVE-2017-14491.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1921-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dnsmasq (PTS)jessie2.72-3+deb8u2vulnerable
jessie (security)2.72-3+deb8u5fixed
stretch2.76-5+deb9u2fixed
stretch (security)2.76-5+deb9u1fixed
buster2.80-1fixed
bullseye2.80-1.1fixed
sid2.81-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dnsmasqsource(unstable)2.76-1
dnsmasqsourcejessie2.72-3+deb8u5DLA-1921-1

Notes

[buster] - dnsmasq <no-dsa> (Minor issue)
[stretch] - dnsmasq <no-dsa> (Minor issue)
https://github.com/Slovejoy/dnsmasq-pre2.76
http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commitdiff;h=d3a8b39c7df2f0debf3b5f274a1c37a9e261f94e

Search for package or bug name: Reporting problems