CVE-2019-14524

NameCVE-2019-14524
DescriptionAn issue was discovered in Schism Tracker through 20190722. There is a heap-based buffer overflow via a large number of song patterns in fmt_mtm_load_song in fmt/mtm.c, a different vulnerability than CVE-2019-14465.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs933808

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
schism (PTS)jessie2:0+20110101-1vulnerable
stretch2:20160521-1vulnerable
buster2:20181223-1vulnerable
bullseye, sid2:20190805-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
schismsource(unstable)2:20190805-1933808

Notes

[buster] - schism <no-dsa> (Minor issue)
[stretch] - schism <no-dsa> (Minor issue)
[jessie] - schism <no-dsa> (Minor issue)
https://github.com/schismtracker/schismtracker/issues/201

Search for package or bug name: Reporting problems