CVE-2019-14697

NameCVE-2019-14697
Descriptionmusl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
musl (PTS)stretch1.1.16-3vulnerable
stretch (security)1.1.16-3+deb9u1vulnerable
buster1.1.21-2vulnerable
bullseye, sid1.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
muslsource(unstable)1.1.23-2

Notes

[buster] - musl <no-dsa> (Minor issue)
[stretch] - musl <no-dsa> (Minor issue)
[jessie] - musl <no-dsa> (Minor issue)
https://git.musl-libc.org/cgit/musl/patch/?id=f3ed8bfe8a82af1870ddc8696ed4cc1d5aa6b441
https://git.musl-libc.org/cgit/musl/patch/?id=6818c31c9bc4bbad5357f1de14bedf781e5b349e
https://www.openwall.com/lists/oss-security/2019/08/06/1

Search for package or bug name: Reporting problems