CVE-2019-14751

NameCVE-2019-14751
DescriptionNLTK Downloader before 3.4.5 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in an NLTK package (ZIP archive) that is mishandled during extraction.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs935201

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nltk (PTS)jessie3.0.0-1vulnerable
stretch3.2.1-2vulnerable
buster3.4-1vulnerable
bullseye, sid3.4.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nltksource(unstable)3.4.5-1low935201

Notes

[buster] - nltk <no-dsa> (Minor issue)
[stretch] - nltk <no-dsa> (Minor issue)
[jessie] - nltk <no-dsa> (Minor issue; user has to configure a compromised server)
https://salvatoresecurity.com/zip-slip-in-nltk-cve-2019-14751/
https://github.com/nltk/nltk/commit/f59d7ed8df2e0e957f7f247fe218032abdbe9a10

Search for package or bug name: Reporting problems