CVE-2019-14806

NameCVE-2019-14806
DescriptionPallets Werkzeug before 0.15.3, when used with Docker, has insufficient debugger PIN randomness because Docker containers share the same machine id.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs940935

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-werkzeug (PTS)jessie0.9.6+dfsg-1+deb8u1fixed
stretch0.11.15+dfsg1-1vulnerable
bullseye, sid, buster0.14.1+dfsg1-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-werkzeugsource(unstable)(unfixed)low940935
python-werkzeugsourcejessie(not affected)

Notes

[buster] - python-werkzeug <no-dsa> (Minor issue)
[stretch] - python-werkzeug <no-dsa> (Minor issue)
[jessie] - python-werkzeug <not-affected> (Vulnerable code not present)
https://github.com/pallets/werkzeug/commit/00bc43b1672e662e5e3b8cecd79e67fc968fa246

Search for package or bug name: Reporting problems