CVE-2019-14833

NameCVE-2019-14833
DescriptionA flaw was found in Samba, all versions starting samba 4.5.0 before samba 4.9.15, samba 4.10.10, samba 4.11.2, in the way it handles a user password change or a new password for a samba user. The Samba Active Directory Domain Controller can be configured to use a custom script to check for password complexity. This configuration can fail to verify password complexity when non-ASCII characters are used in the password, which could lead to weak passwords being set for samba users, making it vulnerable to dictionary attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2668-1, DLA-3563-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)buster2:4.9.5+dfsg-5+deb10u3vulnerable
buster (security)2:4.9.5+dfsg-5+deb10u4fixed
bullseye (security), bullseye2:4.13.13+dfsg-1~deb11u5fixed
bookworm, bookworm (security)2:4.17.12+dfsg-0+deb12u1fixed
trixie2:4.19.5+dfsg-1fixed
sid2:4.19.5+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourcestretch2:4.5.16+dfsg-1+deb9u4DLA-2668-1
sambasourcebuster2:4.9.5+dfsg-5+deb10u4DLA-3563-1
sambasource(unstable)2:4.11.1+dfsg-2

Notes

[jessie] - samba <no-dsa> (Minor issue)
https://www.samba.org/samba/security/CVE-2019-14833.html

Search for package or bug name: Reporting problems