CVE-2019-14856

NameCVE-2019-14856
Descriptionansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)stretch2.2.1.0-2+deb9u1fixed
stretch (security)2.2.1.0-2+deb9u2fixed
buster2.7.7+dfsg-1fixed
buster (security)2.7.7+dfsg-1+deb10u1fixed
bookworm, bullseye, sid2.10.7+merged+base+2.10.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesource(unstable)(not affected)

Notes

- ansible <not-affected> (Incomplete fix for CVE-2019-10206 not applied)
https://github.com/ansible/ansible/pull/63351
https://bugzilla.redhat.com/show_bug.cgi?id=1760829

Search for package or bug name: Reporting problems