CVE-2019-14866

NameCVE-2019-14866
DescriptionIn all versions of cpio before 2.13 does not properly validate input files when generating TAR archives. When cpio is used to create TAR archives from paths an attacker can write to, the resulting archive may contain files with permissions the attacker did not have or in paths he did not have access to. Extracting those archives from a high-privilege user without carefully reviewing them may lead to the compromise of the system.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1981-1
NVD severitymedium
Debian Bugs941412

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cpio (PTS)stretch2.11+dfsg-6vulnerable
buster2.12+dfsg-9vulnerable
bullseye2.13+dfsg-2fixed
sid2.13+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cpiosourcejessie2.11+dfsg-4.1+deb8u2DLA-1981-1
cpiosource(unstable)2.13+dfsg-1low941412

Notes

[buster] - cpio <no-dsa> (Minor issue)
[stretch] - cpio <no-dsa> (Minor issue)
https://lists.gnu.org/archive/html/bug-cpio/2019-08/msg00003.html
http://git.savannah.gnu.org/cgit/cpio.git/commit/?id=7554e3e42cd72f6f8304410c47fe6f8918e9bfd7

Search for package or bug name: Reporting problems