CVE-2019-14973

NameCVE-2019-14973
Description_TIFFCheckMalloc and _TIFFCheckRealloc in tif_aux.c in LibTIFF through 4.0.10 mishandle Integer Overflow checks because they rely on compiler behavior that is undefined by the applicable C standards. This can, for example, lead to an application crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs934780

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)jessie4.0.3-12.3+deb8u5vulnerable
jessie (security)4.0.3-12.3+deb8u8vulnerable
stretch (security), stretch4.0.8-2+deb9u4vulnerable
buster4.0.10-4vulnerable
bullseye, sid4.0.10+git190818-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)4.0.10+git190814-1medium934780
tiff3source(unstable)(unfixed)medium

Notes

https://gitlab.com/libtiff/libtiff/merge_requests/90
https://gitlab.com/libtiff/libtiff/commit/1b5e3b6a23827c33acf19ad50ce5ce78f12b3773

Search for package or bug name: Reporting problems