CVE-2019-15151

NameCVE-2019-15151
DescriptionAdPlug 2.3.1 has a double free in the Cu6mPlayer class in u6m.h.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
adplug (PTS)jessie2.2.1+dfsg3-0.1vulnerable
jessie (security)2.2.1+dfsg3-0.1+deb8u1vulnerable
stretch2.2.1+dfsg3-0.4vulnerable
sid, buster2.2.1+dfsg3-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
adplugsource(unstable)(unfixed)high

Notes

[buster] - adplug <no-dsa> (Minor issue)
[stretch] - adplug <no-dsa> (Minor issue)
[jessie] - adplug <no-dsa> (Minor issue)
https://github.com/adplug/adplug/issues/91

Search for package or bug name: Reporting problems