CVE-2019-15220

NameCVE-2019-15220
DescriptionAn issue was discovered in the Linux kernel before 5.2.1. There is a use-after-free caused by a malicious USB device in the drivers/net/wireless/intersil/p54/p54usb.c driver.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1919-1, DLA-1930-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1fixed
stretch (security)4.9.210-1+deb9u1fixed
buster4.19.146-1fixed
buster (security)4.19.152-1fixed
bullseye, sid5.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie3.16.74-1DLA-1930-1
linuxsourcestretch4.9.189-1
linuxsourcebuster4.19.67-1
linuxsource(unstable)5.2.6-1
linux-4.9sourcejessie4.9.189-3~deb8u1DLA-1919-1

Notes

https://git.kernel.org/linus/6e41e2257f1094acc37618bf6c856115374c6922

Search for package or bug name: Reporting problems