CVE-2019-15531

NameCVE-2019-15531
DescriptionGNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1904-1, DLA-2851-1
Debian Bugs935553

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libextractor (PTS)buster1:1.8-2+deb10u1fixed
bullseye1:1.11-2fixed
bookworm, sid1:1.11-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libextractorsourcejessie1:1.3-2+deb8u5DLA-1904-1
libextractorsourcestretch1:1.3-4+deb9u4DLA-2851-1
libextractorsourcebuster1:1.8-2+deb10u1
libextractorsource(unstable)1:1.9-2935553

Notes

https://bugs.gnunet.org/view.php?id=5846
https://git.gnunet.org/libextractor.git/commit/?id=d2b032452241708bee68d02aa02092cfbfba951a

Search for package or bug name: Reporting problems