CVE-2019-15551

NameCVE-2019-15551
DescriptionAn issue was discovered in the smallvec crate before 0.6.10 for Rust. There is a double free for certain grow attempts with the current capacity.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rust-smallvec (PTS)buster0.6.8-1vulnerable
bullseye, sid0.6.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rust-smallvecsource(unstable)0.6.10-1high

Notes

https://github.com/servo/rust-smallvec/issues/148
https://rustsec.org/advisories/RUSTSEC-2019-0009.html

Search for package or bug name: Reporting problems