CVE-2019-15608

NameCVE-2019-15608
DescriptionThe package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-yarnpkg (PTS)buster1.13.0-1+deb10u1vulnerable
bullseye1.19.1-1fixed
sid1.21.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-yarnpkgsource(unstable)1.19.1-1

Notes

https://hackerone.com/reports/703138

Search for package or bug name: Reporting problems