CVE-2019-15666

NameCVE-2019-15666
DescriptionAn issue was discovered in the Linux kernel before 5.0.19. There is an out-of-bounds array access in __xfrm_policy_unlink, which will cause denial of service, because verify_newpolicy_info in net/xfrm/xfrm_user.c mishandles directory validation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1919-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.72-1fixed
stretch4.9.189-3fixed
stretch (security)4.9.168-1+deb9u5vulnerable
buster4.19.67-2fixed
buster (security)4.19.37-5+deb10u2vulnerable
bullseye, sid5.2.9-2fixed
linux-4.9 (PTS)jessie (security)4.9.189-3~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.2.6-1high
linuxsourcebuster4.19.67-1high
linuxsourcejessie3.16.72-1high
linuxsourcestretch4.9.184-1high
linux-4.9sourcejessie4.9.189-3~deb8u1highDLA-1919-1

Notes

https://git.kernel.org/linus/b805d78d300bcf2c83d6df7da0c818b0fee41427

Search for package or bug name: Reporting problems