CVE-2019-15807

NameCVE-2019-15807
DescriptionIn the Linux kernel before 5.1.13, there is a memory leak in drivers/scsi/libsas/sas_expander.c when SAS expander discovery fails. This will cause a BUG and denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1919-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.72-1vulnerable
stretch4.9.189-3fixed
stretch (security)4.9.168-1+deb9u5vulnerable
buster4.19.67-2fixed
buster (security)4.19.37-5+deb10u2vulnerable
bullseye, sid5.2.9-2fixed
linux-4.9 (PTS)jessie (security)4.9.189-3~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.2.6-1high
linuxsourcebuster4.19.67-1high
linuxsourcestretch4.9.184-1high
linux-4.9sourcejessie4.9.189-3~deb8u1highDLA-1919-1

Notes

https://git.kernel.org/linus/3b0541791453fbe7f42867e310e0c9eb6295364d

Search for package or bug name: Reporting problems