CVE-2019-16222

NameCVE-2019-16222
DescriptionWordPress before 5.2.3 has an issue with URL sanitization in wp_kses_bad_protocol_once in wp-includes/kses.php that can lead to cross-site scripting (XSS) attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1960-1
NVD severitymedium (attack range: remote)
Debian Bugs939543

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17vulnerable
jessie (security)4.1.27+dfsg-0+deb8u1fixed
stretch, stretch (security)4.7.5+dfsg-2+deb9u5vulnerable
bullseye, buster5.0.4+dfsg1-1vulnerable
sid5.2.4+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)5.2.3+dfsg1-1medium939543
wordpresssourcejessie4.1.27+dfsg-0+deb8u1mediumDLA-1960-1

Notes

https://core.trac.wordpress.org/changeset/45997
https://github.com/WordPress/WordPress/commit/30ac67579559fe42251b5a9f887211bf61a8ed68

Search for package or bug name: Reporting problems