CVE-2019-16249

NameCVE-2019-16249
DescriptionOpenCV 4.1.1 has an out-of-bounds read in hal_baseline::v_load in core/hal/intrin_sse.hpp when called from computeSSDMeanNorm in modules/video/src/dis_flow.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opencv (PTS)jessie2.4.9.1+dfsg-1+deb8u1fixed
jessie (security)2.4.9.1+dfsg-1+deb8u2fixed
stretch2.4.9.1+dfsg1-2fixed
buster3.2.0+dfsg-6fixed
bullseye, sid4.2.0+dfsg-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opencvsource(unstable)(not affected)

Notes

- opencv <not-affected> (Vulnerable code not present)
https://github.com/opencv/opencv/issues/15481
https://github.com/opencv/opencv/commit/cd7fa04985b10db5e66de542725d0da57f0d10b6
Issue was present in experimental, but suites up to unstable never were
shiping the vulnerable code.

Search for package or bug name: Reporting problems