CVE-2019-16275

NameCVE-2019-16275
Descriptionhostapd before 2.10 and wpa_supplicant before 2.10 allow an incorrect indication of disconnection in certain situations because source address validation is mishandled. This is a denial of service that should have been prevented by PMF (aka management frame protection). The attacker must send a crafted 802.11 frame from a location that is within the 802.11 communications range.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1922-1, DSA-4538-1
NVD severitylow
Debian Bugs940080

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie2.3-1+deb8u5vulnerable
jessie (security)2.3-1+deb8u9fixed
stretch (security), stretch2:2.4-1+deb9u4vulnerable
buster2:2.7+git20190128+0c1e29f-6vulnerable
buster (security)2:2.7+git20190128+0c1e29f-6+deb10u1fixed
bullseye, sid2:2.9-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasource(unstable)2:2.9-2940080
wpasourcebuster2:2.7+git20190128+0c1e29f-6+deb10u1DSA-4538-1
wpasourcejessie2.3-1+deb8u9DLA-1922-1

Notes

https://www.openwall.com/lists/oss-security/2019/09/11/7
https://w1.fi/security/2019-7/

Search for package or bug name: Reporting problems