CVE-2019-16335

NameCVE-2019-16335
DescriptionA Polymorphic Typing issue was discovered in FasterXML jackson-databind before 2.9.10. It is related to com.zaxxer.hikari.HikariDataSource. This is a different vulnerability than CVE-2019-14540.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1943-1, DSA-4542-1
NVD severityhigh (attack range: remote)
Debian Bugs940498

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jackson-databind (PTS)jessie2.4.2-2+deb8u4vulnerable
jessie (security)2.4.2-2+deb8u9fixed
stretch2.8.6-1+deb9u5vulnerable
stretch (security)2.8.6-1+deb9u6fixed
buster2.9.8-3vulnerable
buster (security)2.9.8-3+deb10u1fixed
bullseye, sid2.10.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jackson-databindsource(unstable)2.10.0-1high940498
jackson-databindsourcebuster2.9.8-3+deb10u1highDSA-4542-1
jackson-databindsourcejessie2.4.2-2+deb8u9highDLA-1943-1
jackson-databindsourcestretch2.8.6-1+deb9u6highDSA-4542-1

Notes

https://github.com/FasterXML/jackson-databind/issues/2449
https://github.com/FasterXML/jackson-databind/commit/73c1c2cc76e6cdd7f3a5615cbe3207fe96e4d3db

Search for package or bug name: Reporting problems