CVE-2019-16370

NameCVE-2019-16370
DescriptionThe PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs941186

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gradle (PTS)stretch3.2.1-1vulnerable
buster4.4.1-6vulnerable
bookworm, bullseye4.4.1-13vulnerable
sid4.4.1-14vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gradlesource(unstable)(unfixed)low941186

Notes

[bullseye] - gradle <ignored> (Minor issue)
[buster] - gradle <ignored> (Minor issue)
[stretch] - gradle <no-dsa> (Minor issue)
[jessie] - gradle <postponed> (Minor issue, old gradle mainly used for building Debian packages with apt signatures)
https://github.com/gradle/gradle/commit/425b2b7a50cd84106a77cdf1ab665c89c6b14d2f

Search for package or bug name: Reporting problems