CVE-2019-16680

NameCVE-2019-16680
DescriptionAn issue was discovered in GNOME file-roller before 3.29.91. It allows a single ./../ path traversal via a filename contained in a TAR archive, possibly overwriting a file during extraction.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1938-1, DSA-4537-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file-roller (PTS)jessie3.14.1-1vulnerable
jessie (security)3.14.1-1+deb8u1fixed
stretch3.22.3-1vulnerable
stretch (security)3.22.3-1+deb9u1fixed
buster3.30.1-2fixed
bullseye, sid3.32.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
file-rollersource(unstable)3.30.0-1medium
file-rollersourcejessie3.14.1-1+deb8u1mediumDLA-1938-1
file-rollersourcestretch3.22.3-1+deb9u1mediumDSA-4537-1

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=794337
https://gitlab.gnome.org/GNOME/file-roller/commit/57268e51e59b61c9e3125eb0f65551c7084297e2

Search for package or bug name: Reporting problems