CVE-2019-16711

NameCVE-2019-16711
DescriptionImageMagick 7.0.8-40 has a memory leak in Huffman2DEncodeImage in coders/ps2.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4712-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)stretch8:6.9.7.4+dfsg-11+deb9u8vulnerable
stretch (security)8:6.9.7.4+dfsg-11+deb9u10vulnerable
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bullseye, sid8:6.9.11.24+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksourcebuster8:6.9.10.23+dfsg-2.1+deb10u1DSA-4712-1
imagemagicksource(unstable)8:6.9.11.24+dfsg-1unimportant

Notes

https://github.com/ImageMagick/ImageMagick/issues/1542
https://github.com/ImageMagick/ImageMagick6/commit/448f301a781405a45717bb53578475de06df973a

Search for package or bug name: Reporting problems