CVE-2019-16729

NameCVE-2019-16729
Descriptionpam-python before 1.0.7-1 has an issue in regard to the default environment variable handling of Python, which could allow for local root escalation in certain PAM setups.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4555-1
NVD severityhigh
Debian Bugs942514

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pam-python (PTS)jessie1.0.4-1vulnerable
jessie (security)1.0.4-1.1+deb8u1vulnerable
stretch1.0.6-1vulnerable
stretch (security)1.0.6-1.1+deb9u1fixed
buster, buster (security)1.0.6-1.1+deb10u1fixed
bullseye1.0.6-1.1+deb10u1vulnerable
sid1.0.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pam-pythonsource(unstable)1.0.7-1942514
pam-pythonsourcebuster1.0.6-1.1+deb10u1DSA-4555-1
pam-pythonsourcestretch1.0.6-1.1+deb9u1DSA-4555-1

Notes

https://bugzilla.suse.com/show_bug.cgi?id=1150510#c1
https://sourceforge.net/p/pam-python/code/ci/0247ab687b4347cc52859ca461fb0126dd7e2ebe/

Search for package or bug name: Reporting problems