CVE-2019-16776

NameCVE-2019-16776
DescriptionVersions of the npm CLI prior to 6.13.3 are vulnerable to an Arbitrary File Write. It fails to prevent access to folders outside of the intended node_modules folder through the bin field. A properly constructed entry in the package.json bin field would allow a package publisher to modify and/or gain access to arbitrary files on a user's system when the package is installed. This behavior is still possible through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs947127

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
npm (PTS)jessie1.4.21+ds-2vulnerable
buster5.8.0+ds6-4+deb10u1fixed
bullseye, sid6.14.5+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
npmsource(unstable)6.13.4+ds-2947127
npmsourcebuster5.8.0+ds6-4+deb10u1
npmsourceexperimental6.13.4+ds-1
npmsourcejessie(unfixed)end-of-life

Notes

[jessie] - npm <end-of-life> (Nodejs in jessie not covered by security support)
https://github.com/npm/cli/security/advisories/GHSA-x8qc-rrcw-4r46
https://blog.npmjs.org/post/189618601100/binary-planting-with-the-npm-cli

Search for package or bug name: Reporting problems