CVE-2019-16777

NameCVE-2019-16777
DescriptionVersions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the previous serve binary. This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs947127

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
npm (PTS)jessie1.4.21+ds-2vulnerable
buster5.8.0+ds6-4vulnerable
bullseye, sid6.13.4+ds-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
npmsource(unstable)6.13.4+ds-2947127
npmsourceexperimental6.13.4+ds-1

Notes

[buster] - npm <no-dsa> (Minor issue)
[jessie] - npm <ignored> (Nodejs in Jessie not covered by security support)
https://github.com/npm/cli/security/advisories/GHSA-4328-8hgf-7wjr
https://blog.npmjs.org/post/189618601100/binary-planting-with-the-npm-cli

Search for package or bug name: Reporting problems