CVE-2019-16781

NameCVE-2019-16781
DescriptionIn WordPress before 5.3.1, authenticated users with lower privileges (like contributors) can inject JavaScript code in the block editor, which is executed within the dashboard. It can lead to an admin opening the affected post in the editor leading to XSS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4599-1
NVD severitylow
Debian Bugs946905

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u6fixed
stretch (security)4.7.19+dfsg-1+deb9u1fixed
buster5.0.10+dfsg1-0+deb10u1fixed
buster (security)5.0.11+dfsg1-0+deb10u1fixed
bullseye5.5.1+dfsg1-1fixed
sid5.5.3+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcejessie(not affected)
wordpresssourcestretch(not affected)
wordpresssourcebuster5.0.4+dfsg1-1+deb10u1DSA-4599-1
wordpresssource(unstable)5.3.2+dfsg1-1946905

Notes

[stretch] - wordpress <not-affected> (Vulnerable Block feature introduce in 5.0)
[jessie] - wordpress <not-affected> (Vulnerable Block feature introduce in 5.0)
https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pg4x-64rh-3c9v
https://hackerone.com/reports/731301
https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/

Search for package or bug name: Reporting problems