CVE-2019-16866

NameCVE-2019-16866
DescriptionUnbound before 1.9.4 accesses uninitialized memory, which allows remote attackers to trigger a crash via a crafted NOTIFY query. The source IP address of the query must match an access-control rule.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4544-1
NVD severitymedium
Debian Bugs941692

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unbound (PTS)jessie1.4.22-3+deb8u3fixed
jessie (security)1.4.22-3+deb8u4fixed
stretch1.6.0-3+deb9u2fixed
buster, buster (security)1.9.0-2+deb10u1fixed
bullseye, sid1.9.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unboundsource(unstable)1.9.4-1941692
unboundsourcebuster1.9.0-2+deb10u1DSA-4544-1
unboundsourcejessie(not affected)
unboundsourcestretch(not affected)

Notes

[stretch] - unbound <not-affected> (Vulnerable code introduced in 1.7.1)
[jessie] - unbound <not-affected> (Vulnerable code introduced in 1.7.1)
https://nlnetlabs.nl/downloads/unbound/CVE-2019-16866.txt
Patch: https://nlnetlabs.nl/downloads/unbound/patch_cve_2019-16866.diff

Search for package or bug name: Reporting problems