CVE-2019-17011

NameCVE-2019-17011
DescriptionUnder certain conditions, when retrieving a document from a DocShell in the antitracking code, a race condition could cause a use-after-free condition and a potentially exploitable crash. This vulnerability affects Thunderbird < 68.3, Firefox ESR < 68.3, and Firefox < 71.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2029-1, DLA-2036-1, DSA-4580-1, DSA-4585-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid123.0-1fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1fixed
buster (security)115.8.0esr-1~deb10u1fixed
bullseye115.7.0esr-1~deb11u1fixed
bullseye (security)115.8.0esr-1~deb11u1fixed
bookworm115.7.0esr-1~deb12u1fixed
bookworm (security)115.8.0esr-1~deb12u1fixed
trixie115.7.0esr-1fixed
sid115.8.0esr-1fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1fixed
buster (security)1:115.8.0-1~deb10u1fixed
bullseye (security), bullseye1:115.7.0-1~deb11u1fixed
bookworm, bookworm (security)1:115.7.0-1~deb12u1fixed
trixie1:115.7.0-1fixed
sid1:115.8.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)71.0-1
firefox-esrsourcejessie68.3.0esr-1~deb8u1DLA-2029-1
firefox-esrsourcestretch68.3.0esr-1~deb9u1DSA-4580-1
firefox-esrsourcebuster68.3.0esr-1~deb10u1DSA-4580-1
firefox-esrsource(unstable)68.3.0esr-1
thunderbirdsourcejessie1:68.3.0-2~deb8u1DLA-2036-1
thunderbirdsourcestretch1:68.3.0-2~deb9u1DSA-4585-1
thunderbirdsourcebuster1:68.3.0-2~deb10u1DSA-4585-1
thunderbirdsource(unstable)1:68.3.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2019-36/#CVE-2019-17011
https://www.mozilla.org/en-US/security/advisories/mfsa2019-37/#CVE-2019-17011
https://www.mozilla.org/en-US/security/advisories/mfsa2019-38/#CVE-2019-17011

Search for package or bug name: Reporting problems