CVE-2019-17069

NameCVE-2019-17069
DescriptionPuTTY before 0.73 might allow remote SSH-1 servers to cause a denial of service by accessing freed memory locations via an SSH1_MSG_DISCONNECT message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
putty (PTS)jessie0.63-10+deb8u1vulnerable
jessie (security)0.63-10+deb8u2vulnerable
stretch (security), stretch0.67-3+deb9u1vulnerable
buster0.70-6vulnerable
bullseye, sid0.73-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puttysource(unstable)0.73-1unimportant

Notes

https://lists.tartarus.org/pipermail/putty-announce/2019/000029.html
Fixed by: https://git.tartarus.org/?p=simon/putty.git;a=commit;h=69201ad8936fe0ff1b8723b7a43accb5e9f1c888
Negligible security impact

Search for package or bug name: Reporting problems