CVE-2019-17267

NameCVE-2019-17267
DescriptionA Polymorphic Typing issue was discovered in FasterXML jackson-databind before 2.9.10. It is related to net.sf.ehcache.hibernate.EhcacheJtaTransactionManagerLookup.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jackson-databind (PTS)jessie2.4.2-2+deb8u4vulnerable
jessie (security)2.4.2-2+deb8u9vulnerable
stretch2.8.6-1+deb9u5vulnerable
stretch (security)2.8.6-1+deb9u6vulnerable
buster2.9.8-3vulnerable
buster (security)2.9.8-3+deb10u1vulnerable
bullseye, sid2.10.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jackson-databindsource(unstable)2.10.0-1high

Notes

https://github.com/FasterXML/jackson-databind/issues/2460
https://github.com/FasterXML/jackson-databind/commit/191a4cdf87b56d2ddddb77edd895ee756b7f75eb

Search for package or bug name: Reporting problems