CVE-2019-17342

NameCVE-2019-17342
DescriptionAn issue was discovered in Xen through 4.11.x allowing x86 PV guest OS users to cause a denial of service or gain privileges by leveraging a race condition that arose when XENMEM_exchange was introduced.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1949-1
NVD severitymedium
Debian Bugs930001

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)stretch (security), stretch4.8.5.final+shim4.10.4-1+deb9u12fixed
buster, buster (security)4.11.3+24-g14b62ab3e5-1~deb10u1fixed
bullseye, sid4.11.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.11.1+92-g6c33308a8d-1930001
xensourcejessie4.4.4lts5-0+deb8u1DLA-1949-1
xensourcestretch4.8.5.final+shim4.10.4-1+deb9u12

Notes

https://xenbits.xen.org/xsa/advisory-287.html

Search for package or bug name: Reporting problems