CVE-2019-17347

NameCVE-2019-17347
DescriptionAn issue was discovered in Xen through 4.11.x allowing x86 PV guest OS users to cause a denial of service or gain privileges because a guest can manipulate its virtualised %cr4 in a way that is incompatible with Linux (and possibly other guest kernels).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs929999

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie4.4.1-9+deb8u10vulnerable
jessie (security)4.4.4lts5-0+deb8u1vulnerable
stretch (security), stretch4.8.5+shim4.10.2+xsa282-1+deb9u11vulnerable
bullseye, sid, buster4.11.1+92-g6c33308a8d-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.11.1+92-g6c33308a8d-1929999

Notes

https://xenbits.xen.org/xsa/advisory-293.html

Search for package or bug name: Reporting problems