CVE-2019-17358

NameCVE-2019-17358
DescriptionCacti through 1.2.7 is affected by multiple instances of lib/functions.php unsafe deserialization of user-controlled data to populate arrays. An authenticated attacker could use this to influence object data values and control actions taken by Cacti or potentially cause memory corruption in the PHP module.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2032-1, DSA-4604-1
NVD severitymedium
Debian Bugs947375

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)jessie0.8.8b+dfsg-8+deb8u6vulnerable
jessie (security)0.8.8b+dfsg-8+deb8u9fixed
stretch0.8.8h+ds1-10vulnerable
stretch (security)0.8.8h+ds1-10+deb9u1fixed
buster1.2.2+ds1-2+deb10u1vulnerable
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.8+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisource(unstable)1.2.8+ds1-1947375
cactisourcebuster1.2.2+ds1-2+deb10u2DSA-4604-1
cactisourcejessie0.8.8b+dfsg-8+deb8u8DLA-2032-1
cactisourcestretch0.8.8h+ds1-10+deb9u1DSA-4604-1

Notes

https://github.com/Cacti/cacti/issues/3026
https://github.com/Cacti/cacti/commit/adf221344359f5b02b8aed43dfb6b33ae5d708c8

Search for package or bug name: Reporting problems