CVE-2019-17563

NameCVE-2019-17563
DescriptionWhen using FORM authentication with Apache Tomcat 9.0.0.M1 to 9.0.29, 8.5.0 to 8.5.49 and 7.0.0 to 7.0.98 there was a narrow window where an attacker could perform a session fixation attack. The window was considered too narrow for an exploit to be practical but, erring on the side of caution, this issue has been treated as a security vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2077-1, DSA-4596-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat7 (PTS)jessie7.0.56-3+deb8u11vulnerable
jessie (security)7.0.56-3+really7.0.100-1fixed
stretch7.0.75-1vulnerable
tomcat8 (PTS)jessie8.0.14-1+deb8u11vulnerable
jessie (security)8.0.14-1+deb8u16vulnerable
stretch (security), stretch8.5.50-0+deb9u1fixed
tomcat9 (PTS)buster9.0.16-4vulnerable
bullseye, sid9.0.31-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat7source(unstable)(unfixed)
tomcat7sourcejessie7.0.56-3+really7.0.99-1DLA-2077-1
tomcat8source(unstable)(unfixed)
tomcat8sourcestretch8.5.50-0+deb9u1DSA-4596-1
tomcat9source(unstable)9.0.31-1

Notes

[jessie] - tomcat8 <no-dsa> (low risk, backport is intrusive)
https://github.com/apache/tomcat/commit/1ecba14e690cf5f3f143eef6ae7037a6d3c16652 (9.0.30)
https://github.com/apache/tomcat/commit/e19a202ee43b6e2a538be5515ae0ab32d8ef112c (8.5.50)
https://github.com/apache/tomcat/commit/ab72a106fe5d992abddda954e30849d7cf8cc583 (7.0.99)

Search for package or bug name: Reporting problems