CVE-2019-17673

NameCVE-2019-17673
DescriptionWordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4599-1
NVD severitymedium
Debian Bugs942459

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u6fixed
stretch (security)4.7.19+dfsg-1+deb9u1fixed
buster5.0.10+dfsg1-0+deb10u1fixed
buster (security)5.0.11+dfsg1-0+deb10u1fixed
bullseye5.5.1+dfsg1-1fixed
sid5.5.3+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcejessie(not affected)
wordpresssourcestretch4.7.5+dfsg-2+deb9u6
wordpresssourcebuster5.0.4+dfsg1-1+deb10u1DSA-4599-1
wordpresssource(unstable)5.2.4+dfsg1-1942459

Notes

[jessie] - wordpress <not-affected> (vulnerable code not present)
https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
https://core.trac.wordpress.org/changeset/46478
https://github.com/WordPress/WordPress/commit/b224c251adfa16a5f84074a3c0886270c9df38de
https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/

Search for package or bug name: Reporting problems