CVE-2019-17674

NameCVE-2019-17674
DescriptionWordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4599-1
NVD severitylow
Debian Bugs942459

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u6fixed
stretch (security)4.7.19+dfsg-1+deb9u1fixed
buster5.0.10+dfsg1-0+deb10u1fixed
buster (security)5.0.11+dfsg1-0+deb10u1fixed
bullseye5.5.1+dfsg1-1fixed
sid5.5.3+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcestretch4.7.5+dfsg-2+deb9u6
wordpresssourcebuster5.0.4+dfsg1-1+deb10u1DSA-4599-1
wordpresssource(unstable)5.2.4+dfsg1-1942459

Notes

[jessie] - wordpress <postponed> (officially fixed in 4.1.28 but no related fix was identified)
https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/
https://wordpress.org/support/wordpress-version/version-4.1.28/
https://github.com/WordPress/WordPress/commit/d1e2b35359df9644f255b7b54a568b56a2c490d7 (4.1.28)

Search for package or bug name: Reporting problems