CVE-2019-17675

NameCVE-2019-17675
DescriptionWordPress before 5.2.4 does not properly consider type confusion during validation of the referer in the admin pages, possibly leading to CSRF.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1980-1
NVD severitymedium
Debian Bugs942459

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17vulnerable
jessie (security)4.1.28+dfsg-0+deb8u1fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u5vulnerable
buster5.0.4+dfsg1-1vulnerable
bullseye, sid5.2.4+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)5.2.4+dfsg1-1942459
wordpresssourcejessie4.1.28+dfsg-0+deb8u1DLA-1980-1

Notes

https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
https://core.trac.wordpress.org/changeset/46477
https://github.com/WordPress/WordPress/commit/b183fd1cca0b44a92f0264823dd9f22d2fd8b8d0
https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/

Search for package or bug name: Reporting problems