CVE-2019-18601

NameCVE-2019-18601
DescriptionOpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data access because remote attackers can make a series of VOTE_Debug RPC calls to crash a database server within the SVOTE_Debug RPC handler.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1982-1
NVD severitymedium
Debian Bugs943587

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openafs (PTS)jessie1.6.9-2+deb8u7vulnerable
jessie (security)1.6.9-2+deb8u9fixed
stretch (security), stretch1.6.20-2+deb9u2vulnerable
buster1.8.2-1vulnerable
bullseye1.8.4~pre1-1vulnerable
sid1.8.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openafssource(unstable)1.8.5-1943587
openafssourcejessie1.6.9-2+deb8u9DLA-1982-1

Notes

http://openafs.org/pages/security/OPENAFS-SA-2019-003.txt

Search for package or bug name: Reporting problems