CVE-2019-18622

NameCVE-2019-18622
DescriptionAn issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs945349

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)stretch4:4.6.6-4+deb9u1fixed
bullseye, sid4:4.9.7+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsourcejessie(not affected)
phpmyadminsourcestretch(not affected)
phpmyadminsource(unstable)4:4.9.2+dfsg1-1945349

Notes

[stretch] - phpmyadmin <not-affected> (vulnerable code is not present)
[jessie] - phpmyadmin <not-affected> (vulnerable code is not present)
https://github.com/phpmyadmin/phpmyadmin/commit/ff541af95d7155d8dd326f331b5e248fea8e7111
https://gist.github.com/ibennetch/4ba7d2fac6f384a5039d697a110e0912
https://www.phpmyadmin.net/security/PMASA-2019-5/

Search for package or bug name: Reporting problems