CVE-2019-18798

NameCVE-2019-18798
DescriptionLibSass before 3.6.3 allows a heap-based buffer over-read in Sass::weaveParents in ast_sel_weave.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsass (PTS)stretch3.4.3-1vulnerable
bullseye, sid, buster3.5.5-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsasssource(unstable)(unfixed)

Notes

https://github.com/sass/libsass/issues/2999

Search for package or bug name: Reporting problems