CVE-2019-18804

NameCVE-2019-18804
DescriptionDjVuLibre 3.5.27 has a NULL pointer dereference in the function DJVU::filter_fv at IW44EncodeCodec.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1985-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
djvulibre (PTS)jessie3.5.25.4-4vulnerable
jessie (security)3.5.25.4-4+deb8u2fixed
stretch3.5.27.1-7vulnerable
buster3.5.27.1-10vulnerable
bullseye, sid3.5.27.1-13vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
djvulibresource(unstable)(unfixed)
djvulibresourcejessie3.5.25.4-4+deb8u2DLA-1985-1

Notes

[buster] - djvulibre <no-dsa> (Minor issue)
[stretch] - djvulibre <no-dsa> (Minor issue)
https://sourceforge.net/p/djvu/bugs/309/
https://sourceforge.net/p/djvu/djvulibre-git/ci/c8bec6549c10ffaa2f2fbad8bbc629efdf0dd125/

Search for package or bug name: Reporting problems