CVE-2019-18841

NameCVE-2019-18841
DescriptionChartkick.js 3.1.0 through 3.1.3, as used in the Chartkick gem before 3.3.0 for Ruby, allows prototype pollution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chartkick.js (PTS)bullseye, sid, buster, stretch2.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chartkick.jssource(unstable)(not affected)

Notes

- chartkick.js <not-affected> (Vulnerability introduced with 3.1.0)
https://github.com/ankane/chartkick/commit/b810936bbf687bc74c5b6dba72d2397a399885fa

Search for package or bug name: Reporting problems