CVE-2019-18889

NameCVE-2019-18889
DescriptionAn issue was discovered in Symfony 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0 through 4.3.7. Serializing certain cache adapter interfaces could result in remote code injection. This is related to symfony/cache.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
symfony (PTS)stretch (security), stretch2.8.7+dfsg-1.3+deb9u3fixed
buster, buster (security)3.4.22+dfsg-2+deb10u1fixed
bookworm, bullseye4.4.19+dfsg-2fixed
sid5.4.0~rc1+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
symfonysourcejessie(not affected)
symfonysourcestretch(not affected)
symfonysourcebuster3.4.22+dfsg-2+deb10u1
symfonysource(unstable)4.3.8+dfsg-1

Notes

[stretch] - symfony <not-affected> (Vulnerable code not present)
[jessie] - symfony <not-affected> (Vulnerable code not present)
https://symfony.com/blog/cve-2019-18889-forbid-serializing-abstractadapter-and-tagawareadapter-instances
https://github.com/symfony/symfony/commit/8817d28fcaacb31fe01d267f6e19b44d8179395a

Search for package or bug name: Reporting problems