CVE-2019-18890

NameCVE-2019-18890
DescriptionA SQL injection vulnerability in Redmine through 3.2.9 and 3.3.x before 3.3.10 allows Redmine users to access protected information via a crafted object query.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4574-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redmine (PTS)stretch3.3.1-4+deb9u2vulnerable
stretch (security)3.3.1-4+deb9u3fixed
bullseye, sid4.0.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redminesource(unstable)3.4.2-1
redminesourcestretch3.3.1-4+deb9u3DSA-4574-1

Notes

https://www.redmine.org/news/125
https://www.redmine.org/projects/redmine/repository/revisions/16196
https://www.redmine.org/issues/32374
https://github.com/redmine/redmine/commit/04d4a1a191c46e4595ed455372e86c66cf3f6ed7#diff-72469d98e80a60152ebcfa998306b5ecL581-R584

Search for package or bug name: Reporting problems