CVE-2019-18934

NameCVE-2019-18934
DescriptionUnbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code execution after receiving a specially crafted answer. This issue can only be triggered if unbound was compiled with `--enable-ipsecmod` support, and ipsecmod is enabled and used in the configuration.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unbound (PTS)jessie1.4.22-3+deb8u3fixed
jessie (security)1.4.22-3+deb8u4fixed
stretch1.6.0-3+deb9u2fixed
buster, buster (security)1.9.0-2+deb10u1vulnerable
bullseye, sid1.9.4-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unboundsource(unstable)(unfixed)unimportant
unboundsourcejessie(not affected)
unboundsourcestretch(not affected)

Notes

[stretch] - unbound <not-affected> (ipsecmod module introduced later)
[jessie] - unbound <not-affected> (ipsecmod module introduced later)
Debian binary packages not built with --enable-ipsecmod
https://nlnetlabs.nl/downloads/unbound/CVE-2019-18934.txt

Search for package or bug name: Reporting problems